Willkommen zu WinUAE!

WinUAE ist eine 32-Bit Windows (95/98/NT) Version des Ultimate Amiga Emulator (UAE). UAE ist ein Versuch von Amiga - Enthusiasten, einen portierbaren Amiga-Emulator unter der GNU Public License zu entwickeln. Der Quellcode aller UAE- Versionen ist verfügbar, und beigesteuerter Code von anderen Entwicklern ist immer willkommen.

WinUAE erlaubt dir, Software für den Amiga unter Windows laufen zu lassen. Generell ist die Kompatibilität ziemlich gut, und es gibt einige Erweiterungen gegenüber einem echten Amiga.

Diese Hilfedatei enthält Informationen über die Vorbereitungen für WinUAE, Beschreibungen zu allen GUI Einstellungen und Information über die eigentliche Emulation und einige Informationen über die echten Amigas (siehe Hintergrundinformationen!).


Eigenschaften / Funktionen

WinUAE bietet eine Fülle von Funktionen, die die eines echten Amigas zum Teil sogar übertreffen:

  • Picasso96 RTG - Unterstützung, sodaß dein "Amiga" mit allen Auflösungen, die deine PC-Grafikkarte beherrscht, betrieben werden kann. P96-RTG ist als eine Zorro-III Grafikkarte implementiert.

  • CD-ROM - Unterstützung, um auf Amiga-CD's zugreifen zu können.

  • Unterstützung des Windows- Dateisystems (FAT16, FAT32, NTFS), damit du deine Amiga-Partitionen einfach als Verzeichnis auf deinem PC anlegen kannst. Das macht es extrem einfach, Daten zwischen dem "Amiga" und dem PC auszutauschen.

  • Hard-Files, um maximale Kompatibilität und ein kleineres Risiko für die PC- Seite zu erreichen.

  • Zorro-III Speichererweiterungsunterstützung, um dem virtuellen Amiga mehr Speicher zur Verfügung zu stellen.

  • Super-Alice custom-chip, mit bis zu 8 MB Chip-Speicher.

  • Virtuelle Netzwerkunterstützung, entweder üner Ethernet oder eine Einwahlverbindung (über die PC- Seite!), daß heißt, daß dum Beispiel für einen Internet-Zugriff im Amiga kein (!!) TCP/IP - Stack benötigt wird (wie zum Beispiel Miami).

  • Unterstützung für einen MIDI-Ausgang.

Und noch viel, viel mehr...


Die Zukunft von UAE

Bernd Schmidt arbeitet immer noch am "Kern" von UAE.

Brian entwickelt im Moment gerade:

  • Den WinUAE Grundcode.

  • AHI - Unterstützung.

Toni Wilen arbeitet an:

  • Verbesserung der Emulation für den AGA Chipsatz. Keine korrupten AGA Bildschirme oder falsches horizontales Scrolling mehr!

  • Speichern des Emulator "Zustandes". Speichert alle Speicher, CPU, Customchip und mehr Zustände. Wichtig für das Speichern und Laden von Spielen, die keine Funktion zum Speichern haben, oder eine andere Formatierung der Diskette haben. Unterstützt nur den "reinen" Amiga und keine UAE - Erweiterungen wie Festplattenemulation oder Picasso96. Dieser Teil ist komplett und funktioniert auch, es müssen nur noch die überflüssigen Dinge entfernt werden, bevor es in WinUAE eingebaut wird. Dies wird geschehen, wenn die Emulation des AA - Chipsatzes fertig ist.

  • Die Unterstützung für das Action Replay 3 ist fertig. Leider ist das AR3 schlecht programmiert und funtkioniert nur mit Kickstart 1.3 und ungefährer A500 Geschwindigkeit. Er hat auch die Unterstützung für HRTMon ("software action replay", funktioniert auch mit AGA und schnellen Prozessoren) fertiggestellt.

  • Ein weiterer Kollege arbeitet an der Implementation von SCSI.

Siehe auch Entwickler für mehr Information über die Leute hinter UAE!

Mögliche Entwicklungen in den nächsten Versionen von UAE:

  • AHI Unterstützung, um die Fähigkeiten der PC- Soundkarte dem Amiga voll zur Verfügung zu stellen.

  • Bessere Unterstützung für das AA- Chipset (die aktuelle Implementierung ist nur im Anfangsstadium).

  • Die Möglichkeit, den Gesamten "Stand" des Emulators zu speichern, und später wieder zu laden. Dies könnte bei den Spielen helfen, die in UAE wegen iherer eigenen Disketten-Formatierung Spielstände nicht abspeichern können.

  • Asynchrone Picasso96 RTG Unterstützung. Wenn der "Amiga" eine P96 - Routine aufruft, wird die GANZE Emulation angehalten, bis DirectX die Aktion abeschlossen hat.

  • Verbesserte Unterstützung der Seriellen Schnittstelle durch ein uaeser.device.

  • Verbesserte Druckerunterstützung durch einen "Amiga" - Druckertreiber, der die ganzen Ausdrucke in Grafiken umwandelt, und an den Windows-Druckmanager übergibt. Dies würde dann auch den Einsatz von Netzwerkdruckern zulassen.

  • Die Möglichkeit echte (!!) Amiga SCSI oder IDE Festplatten zu lesen/beschreiben, wenn du sie an den PC anschließt. Das würde es sehr einfach machen, große Datenmengen zwischen dem Amiga und dem PC auszutauschen.

  • Schnellere 680x0 Emulation.

  • WarpOS API - Unterstützung.


Bekannte Fehler

WinUAE hat eineige Fehler, die den Programmieren bekannt sind. Bitte schau dir diese Liste an, bevor du ihnen eine Mail mit einer Fehlermeldung schickst. Überflüssige Mails sollten doch vermieden werden .... :)

  • AGA - Unterstützung ist zur Zeit noch sehr "primitiv". Wenn du keine AA- Spiele spielen willst, sondern nur mehr Farben während der Emulation haben möchtest, dann ist es besser, Picasso96 RTG zu benutzen.
  • Es kann sein, daß das Speichern in einigen Spielen nicht funktionieren, da sie eine spezielle Formatierung der Disketten erfordert, die UAE (bis jetzt noch) nicht emuliert. Näheres bei Kompatibilität.
  • Die Sprite-Kollisionsabfrage ist noch nicht perfekt. Spiele, bei denen das Auswirkungen hat:
    • Deluxe Galaga
    • Hybris
    • Battle Squadron
  • Die Parallel-Port Emulation ist irgendwie unverläßlich.
  • ShapeShifter (ein 680x0 Mac Emulator für den Amiga) hat einige Probleme mit verschiedenen Einstellungen
  • Einige Leute berichteten über einen Bug mit dem Installer (im "Amiga"), der Verzeichnisse nicht richtig erstellen konnte.


Links

Hier findest du die besten Seiten zur Amiga-Emulation und zum Amiga:

Offizielle UAE Seiten: |
The official UAE page | Bernd's offizielle UAE Seite.
The official WinUAE page | The Haupt-WinUAE Seite.
WinUAE Announcement List | Benachrichtigung, wenn eine neue Version fertig ist.
Essential Programs: |
Direct X | Benötigt, um das Beste aus WinUAE rauszuholen.
Picasso 96 | Besorg dir die neueste Version des Treibers hier.
Erweiterungen/Tools: |
Amiga In A Box | Vorkonfiguriertes setup für den Amiga.
ADFOpus | Windowsprogramm zum manipulieren von adf's.
Nützliche Seiten: |
WinUAE Discussion Board | Wenn noch Fragen übrig sind, schau hier vorbei.
Amiga Joystick 2 PC | Verbinde deinen Amiga-Joystick mit dem PC.
Spiele: |
Back To The Roots | Nicht nur Spiele - empfohlene Seite!
Amiga Sector One | Super Seite mit Spielen und mehr.
Amiga Emulation Zone | Gute Seite - nur Spiele.
Original Amiga: |
Aminet | Das größte Archiv an Amiga-Software.
AIG | Extrem viele Informationen über den Amiga.
Amiga News | Mehrsprachige Amiga-Newsseite.


Vorbereitungen

Um mit WinUAE einen Amiga zu emulieren, müssen einige Anforderungen erfüllt werden. In diesem Abschnitt wird beschrieben, was man alles braucht, und wie man es bekommt...

WinUAE - Installer

Die einzelnen Themen:

  • Voraussetzungen
  • Transrom & Transdisk


Voraussetzungen

Wenn du Windows 95 verwendest und DirectX nicht installiert hast, dann mußt du dir zuerst eine Kopie besorgen. UAE funktioniert mit älteren Versionen von DirectX, sodaß eigentlich keine Probleme auftreten sollten, wenn auf deinem Rechner schon einmal ein Spiel installiert war.

Windows NT 4.0 hat DirectX bereits eingebaut, aber du wirst dazupassende Grafikkartentreiber brauchen. Leider unterstützen viele Treiber DirectX nicht vollständig. Es kann also sein, daß du dir vom Hersteller deiner Grafikkarte ein Treiber-Update besorgen mußt.

WinUAE braucht etwas Amiga Software, um zu funktionieren:

  • Eine Kopie eines Kickstart-ROMs (auch als ROM-image, ROM-file, KickFile, oder KickROM bekannt). Wenn du einen Amiga besitzt, kannst du ein ROM-Image aus deinem Amiga auslesen, indem du das Programm Transrom verwendest. Wenn du keinen Amiga mehr besitzt, kannst du dir eine legale Kopie eines solchen ROMs bei Cloanto besorgen. Die Software Amiga Forever enthält alles, was man zur Emulation eines Amigas braucht.
  • Eine Kopie von Amiga OS Disketten (meist auch Workbench genannt). Wenn du einen Amiga besitzt, kannst du die Disketten mit dem Tool Transdisk umwandeln. Wenn du KEINEN Amiga mehr besitzt, kannst du dir eine legale Kopie der Disketten ebenfalls bei Cloanto besorgen (Amiga Forever).

ANMERKUNG: Amiga Forever enthält auch ein Utility namens Amiga Explorer, das dir ermöglicht, einen echten Amiga mit einem Windows-Rechner zu verbinden, um ohne Schwierigkeiten Dateien zwischen den beiden System auszutauschen.

ANMERKUNG: Die Amiga Software (ROMs UND Workbench) ist rechtlich geschütztes Material, es ist NICHT frei erhältlich! Keiner des WinUAE-Teams werden irgendwelche ROMs oder Workbench-Disketten zur Verfügung stellen!

WinUAE ist ein recht leistungshungriges Programm. Es benötigt einen schnellen Rechner, um den Amiga in guter Geschwindigkeit zu emulieren. Je schneller der Rechner, auf dem UAE läuft, desto besser...

Vorschlag einer vernünftigen Konfiguration:

  • Pentium 233MMX oder höher
  • 64-MB RAM
  • PCI Soundkarte
  • PCI oder AGP Grafikkarte
  • Win98 mit DirectX 6.0 (oder höher), oder WinNT 4.0 mit Service Pack 3 (oder höher)
  • Joystick

Wenn du all diese Dinge beisammen hast, kannst du WinUAE starten, und beginnen, mittels des GUI einzustellen. Wenn du damit auch fertig bist, und die Emulation läuft, gibt es trotzdem einiges, das man wissen sollte: Die Emulation enthält alles, was man wissen sollte, um WinUAE richtig zu nutzen.


Transrom & Transdisk

Zugriffe auf das Diskettenlaufwerk können nur über einen Umweg emuliert werden, da PCs keine Amiga-Disketten lesen können. UAE verwendet "Diskfiles", das sind genaue Abbilder des Inhalts einer Amiga-Diskette. Solche Diskfiles sind 901120 Bytes groß und können mit dem Tool Transdisk, das UAE beiliegt erstellt werden. Um WinUAE laufen lassen zu können, benötigst du außerdem ein Abbild eines Amiga-Kickstart-ROMs. Dieses kann aus Copyrightgründen nicht mit WinUAE vertrieben werden. Es muß mit dem Tool Transrom erzeugt werden.

Die beiden Programme sind im Unterverzeichnis "Amiga Programs" zu finden. Du mußt sie zunächst auf deinen Amiga kopieren, entweder über ein serielles Nullmodem-Kabel oder mit Hilfe eines Amiga-Programms wie etwa CrossDOS oder MessyDOS, die es ermöglichen, PC-Disks mit einem Amiga zu lesen und zu beschreiben. Die gleiche Methode kann dann auch benutzt werden, um Amiga-Dateien auf den PC zu kopieren.

  • Wenn du die Lösung mit dem Nullmodemkabel benutzen willst, wirst du zwei Terminalprogramme benötigen, sowohl für den PC als auch für den Amiga. 68000er Amigas erreichen normalerweise ungefähr 3000cps über das Nullmodemkabel. Dazu wird das originale serial.device verwendet. Es gibt einige Ersatzprogramme, mit denen die Übertragungsleistung auf bis zu 5500cps gesteigert werden kann. Die Programme sind im Aminet zu finden.
  • Wenn du CrossDOS benutzen willst, kannst du die Disketten- oder Kickstartdatei komprimieren (z.B. mit LHA), sie auf eine 720kB Diskette kopieren und am PC wieder auslesen. CrossDOS ist seit einiger Zeit Bestandteil des Amiga-Betriebssystems, und MessyDOS ist frei erhältlich. Beachte, daß in vielen Amigas nur DD-Laufwerke eingebaut sind, die PC-üblichen HD-Disketten lassen sich damit nicht verarbeiten.

Für die Bedienung der jeweiligen Programme lies bitte deren Anleitung durch.

Nachdem die Dateien auf den Amiga kopiert wurden, kannst du sie über die CLI aufrufen:

transrom >RAM:kick.rom

Dieser Befehl erzeugt eine 524288 Byte große Kickstart-Datei in der Ramdisk. Diese mußt du dann auf deinen PC kopieren. Bei der Konfiguration von UAE muß dann diese Datei in der Karte ROM angegeben werden.

Mit

transdisk >RAM:df0.adf

wird die in DF0: liegende Diskette in ein Diskettenabbild umgewandelt, welches wiederum in der Ramdisk gespeichert wird. Hierbei kann ein Problem auftreten, wenn Ihr Amiga wenig Speicher hat (wenn er _sehr_ wenig Speicher hat, funktioniert schon der obige transrom-Befehl nicht; dann mußt du die Datei auf einer Festplatte speichern). Du kannst die Diskette in mehreren Stücken übertragen. Eine Amiga-Diskette hat 80 Spuren (0..79); mit den Befehlen

transdisk >ram:df0_1.adf -s 0 -e 19
transdisk >ram:df0_2.adf -s 20 -e 39
transdisk >ram:df0_3.adf -s 40 -e 59
transdisk >ram:df0_4.adf -s 60 -e 79

werden vier Teil-Disketten-Abbilder erstellt, (z.B. enthält df0_1.adf gerade die Spuren 0 bis 19). Die vier Dateien lassen sich dann auf dem PC wieder zu einer zusammensetzen, unter dem DOS-Prompt mit

COPY /B df0_1.adf+df0_2.adf+df0_3.adf+df0_4.adf df0.adf

UAE benötigt die Datei "kick.rom" (524288 Byte) und ein Diskettenabbild (901120 Byte), um etwas Sinnvolles zu tun. Die Diskette kann in der Karte Floppies im GUI eingelegt werden.

Es ist auch möglich, die Daten einer ADF - Datei zurück auf eine echte Amiga-Diskette zu schreiben. Kopiere die ADF auf einen Amiga, und lege eine Diskette in df0 ein. Dann benötigst du nur noch das Programm Transrom. Mit dem Befehl

transdisk -w name.adf

wird der Inhalt der ADF - Datei zurück auf die eingelegte Diskette geschrieben. Name.adf muß durch den gewünschten Dateinamen ersetzt werden!

ACHTUNG: Die Datei, die das Kickstartabbild enthält, darf nicht weitergegeben werden, da sie Code enthält, dessen Copyright Amiga hält. Ebenso dürfen die meisten Diskettenabbilder (etwa die Workbench, oder kommerzielle Spiele) nicht weiterverbreitet werden. Du darfst mit UAE nur nur Software benutzen, für die du das Nutzungsrecht hast.


Das GUI

WinUAE GUI

WinUAE besitzt ein wirklich "mächtiges" GUI (= eine Grafische Benutzeroberfläche), um alle Einstellungen für den "Amiga" zu machen. Um die verschiedenen Möglichkeiten zu sehen, müssen nur die einzelnen Registrierkarten angeklickt werden.

WinUAE - Info

Einzelheiten zu den verschiedenen Karten:

  • Configurations
  • RAM
  • ROM
  • CPU
  • Display
  • Sound
  • Floppies
  • Hard Drives
  • Game and I/O Ports
  • Misc.


Konfiguration

Configuration Settings

Diese Einstellungen erlauben es dir, verschiedene Konfigurationsdateien anzulegen und zu verwalten. Diese Dateien haben die Endung uae, und enthalten alle Einstellungen, die im GUI zur Verfügung stehen.

WinUAE - Konfigurationen

Laden einer Konfiguration:

Du kannst eine Konfiguration laden, indem du sie anwählst und auf "Load" - Knopf drückst, oder sie einfach doppelklickst.

Du kannst auch direkt vom Explorer oder einer Verknüpfung auf eine .uae - Datei doppelklicken. Die Konfiguration wird dann geladen, und wenn die Option Show GUI on Startup ausgeschaltet ist, wird WinUAE sofort mit dieser Konfiguration die Emulation starten, und das GUI gar nicht anzeigen.

Speichern einer Konfiguration:

Die Konfiguration auswählen, und auf den Knopf "Save" drücken. Wenn du eine Konfiguration geändert hast, und sie unter einem anderen Namen speichern willst, ändere einfach das Feld Name. Genauso funktioniert das auch mit der Beschreibung (Description).

Löschen einer Konfiguration:

Einfach eine Konfiguration auswählen und auf Delete klicken.


RAM

Diese Einstellungen bestimmen, wieviel RAM für den "Amiga" verwendet wird.

WinUAE - RAM

Über die Regler kann der Speicher, der dem Amiga dann zur Verfügung steht, ganz einfach vergeben werden. Sollte mehr RAM ausgewählt werden, als der Computer zur Verfügung hat, wird Windows einfach in die Datei Win386.swp auslagern (was ziemlich langsam ist).

Hintergrundinformation:

  • Das Fast RAM ist für die CPU alleine reserveriet, die Kapazität hängt von der CPU ab.
  • Chip RAM wird von der CPU und den Custom Chips geteilt. Es ist vergleichbar mit Video RAM und Sound Puffer in anderen Computersystemen.

Je nach Prozessortyp kann man den RAM-Speicher auf bis zu 10 MB oder theoretisch bis 2 GB ausbauen und direkt verwenden, ohne daß zusätzliche Speichermanagement-Software nötig wäre. Das Limit von 2 GB gilt für die AMIGA-Modelle A3000 und A4000. Auf der Hauptplatine dieser Rechner lassen sich bis zu 18 MB unterbringen, und für jeden der vier Zorro-III-Bussteckplätze gibt es Speicherkarten. Somit kann der Speicherausbau auf das Maximum erhöht werden!


ROM

Diese Karte enthält Einstellungsmöglichkeiten für das Kick-Image.

WinUAE - ROM

Key File erlaubt dir, ein Key-File zum entschlüsseln der Images von Cloanto's Amiga Forever CD-ROM zu verwenden.

ShapeShifter support wird die ShapeShifter 'PrepareEmul' Unterstützung einschalten, sodaß du dein ROM nicht mehr KickShiften mußt, wenn du ShapeShifter verwendest. Diese Option erlaubt auch Amiga Forever Benutzern (verschlüsselte ROMs können nicht "ge-KickShift-ed" werden), ShapeShifter zu verwenden.

ACHTUNG: ShapeShifter ist ein Mac - Emulator für den Amiga. Wenn du das nicht gewußt hast, verwende diese Option nicht!

Hintergrundinformation:

Der erste Amiga (A1000) hate ein kleines ROM, das Code ewhich contained code to load the basic operating system from a disk, known as the "Kickstart disk" into 256 kilobytes of RAM, which was then transformed into ROM by disabling the write signal to this RAM. Of course, the contents of this pseudo-ROM was lost when the computer was turned off. The point of using RAM was that Commodore wanted to be able to continue developing the operative system without requiring people to change ROMs when the new version was available; instead, they could just distribute new "Kickstart" disks, which they did three times, upgrading version 1.0 to 1.1, 1.2. Version 2.0 was too large to fit into this pseudo-ROM, and that's the reason why Amiga 1000s cannot run the modern versions of the Amiga OS.


CPU

Diese Einstellungen legen fest, welche Motorola 68000 CPU emuliert werden soll.

WinUAE - CPU

CPU Typ:

68000 ist der erste Prozessor der 68k-Familie. Er wurde im Amiga 1000, 500 und 2000 verwendet.

68010 ist ein leicht verbessertes 68K- Mitglied, wurde aber nie in einem echten Amiga verwendet.

68020 ist ein weit mehr fortgeschrittener Prozessor, mit einigen neuen Befehlen. Es ist ein reiner 32-BIT Prozessor. Wurde im A2500 verbaut.

68EC020 ist die Gleiche CPU wie die "original" 68020, beherrscht aber nur 24 Adressbits. Diese CPU wurde im A1200 verwendet, und erlaubt keine Zorro-III Erweiterungskarten. Weil WinUAE aber virtuelle Zorro-III Erweiterungskarten verwendet, um Picasso96 zu unterstützen, ist Picasso96 RTG mit diesem CPU-Typ NICHT möglich.

68EC020/68881 ist ähnlich zum 68EC020, hat aber eine FPU (Fließkommaeinheit) für schnellere mathematische Operationen.

68020/68881 ist die beste Kombination, die WinUAE emulieren kann. Wurde im A2500 verbaut.

CPU Emulation Speed:

Fastest possible läßt die CPU-Emulation so viele Durchläufe wie möglich machen, während die Emulation für die Custom-chips trotzdem in den erforderlichen Abständen durchgeführt wird. Es ist wichtig, daß Grafik und Sound synchron zueinander sind, egal wie schnell der PC ist.

Approximate A500 speed limitiert die Emulation der CPU auf das selbe Level, daß ein echter A500 haben würde. In anderen Worten: es wird die selbe Anzahl von Instruktionen zwischen den Grafik-Erneuerungen bearbeitet, wie bei einem echten A500.

Adjustable between CPU and chipset erlaubt dir, die Balance zwischen der Custom-chip emulation und der CPU-Geschwindigkeit zu verstellen. Einige Spiele und Demos laufen nur, wenn hier die richtigen Einstellungen angegeben sind. Diese Einstellung ist die Einzige, die während der Emulation verstellt werden kann.

Slow but more compatible ist nur bei der 68000er CPU wählbar. Einige Spiele benötigen diese Einstellung für eine besser Kompatibilität.


Darstellung

Display

Diese Einstellungen erlauben dir, auszuwählen, wie WinUAE die Amiga- Grafik darstellt.

WinUAE - Bildschirm

UAE verwendet DirectX, um die Grafik auszugeben. Du benötgst mindestens DirectX 3. Sei WinUAE 0.8.8r7 kann auch die DirectX 6 Unterstützung eingeschaltet werden, um die Geschwindigkeit zu erhöhen. Dies kann bei Misc. erledigt werden. Das standardmäßige UAE Pixelformat ist 16 Bit.

In der Picasso96 Sektion steht mehr Information über dieses Merkmal.

Amiga screen resolution

Hier kann man auswählen, welche Auflösung der "Amiga" dann haben soll. Bei Select kann man die Auflösung im Vollbildmodus auswählen, mit Width und Height kann man die größe für die Fensterdarstellung festlegen.

Settings

Correct aspect läßt bestimmte Linien der Darstellung weg, um sie besser in den Bildschirm einzupassen.

Full-Screen stellt den Amiga im Vollbildmodus dar. Wenn diese Option ausgeschaltet ist, erfolgt die Darstellung in einem Fenster.

Lo-Res veranlaßt UAE, jeden zweiten, horizontalen Pixel nicht zu zeichnen.

Full Screen RTG aktiviert die Unterstützung für RTG, wenn es nicht aktiviert ist, erfolgt die Darstellung der "Full-Screen" Modi in einem Fenster.

Line Mode

Normal zeichnet jede Linie einmal.

Doubled zeichnet jede Linie zweimal. Damit werden "interlace" - Modi gut emuliert, die Darstellungsfläche wird jedoch 2mal so hoch.

Scanline zeichnet nicht jede Linie, und läßt diese dann Schwarz.

.

Centering

Mit Hilfe dieser Optionen kann man festlegen, ob und wie UAE den Amiga-Bildschirm zentriert (horizontal und/oder vertikal).

Chipset

In diesem Abschnitt kann der Chipsatz des "Amigas" gewählt werden. Siehe Hintergrundinformation für die Beschreibung der einzelnen Chipsätze!

Detect 16-bit Pixel Format stellt das Grafikformat deines PC's mit 640x480 bei 60Hz mit einer Farbtiefe von 16 Bit fest. Dazu wird der Grafikmodus kurz (ca. 2 Sekunden) auf dieses Format umgeschaltet. Dies sollte jedes mal gemacht werden, wenn UAE neu installiert oder eine neue Grafikkarte eingebaut worden ist.

Hintergrundinformation:

Im ersten AMIGA, dem A1000, verrichteten die Chips "Agnus", "Paula" und "Denise" ihre Arbeit. Sie bilden ein spezialisiertes Multiprozessorsystem, das dem Hauptprozessor viel zeitkritische Arbeit abnimmt. Dazu zählen die einfache Wiedergabe der Bildinformationen, 4kanalige DMA-Tonausgabe, Floppy-Ansteuerung, allgemeine DMA-Verwaltung und noch mehr. In den neuesten AMIGAs steckt der "AA-Chipsatz", der neben "Paula" die verbesserten Chips "Alice" (für Agnus) und "Lisa" (für Denise) umfaßt.

  • OCS (Original Chip Set): Dies war der erste Amiga- Chipsatz, verwendet im Amiga 1000. Er umfaßt die Chips Paula, Agnus und Denise. Damit kann man Grafik in Auflösungen bis 640x512 und in bis zu 4096 Farben darstellen.
  • ECS (Enhanced Chip Set): Dies war die nächste Generation. Die Namen blieben bis auf Vorsätze wie "Fat Agnus" erhalten. Nur Agnus und Denise wurden dabei geändert. Gegenüber OCS wurden etwas höhere Auflösungen bereitgestellt, jedoch noch keine Erweiterung der Farbpalette.
  • AGA (Advanced Graphics Architecture): Die aktuelle Generation entstand in den Labors als AA-Chipsatz (für Advanced Amiga), wurde aber in manchen Ländern später als AGA (Advanced Graphics Architecture) vermarktet. Agnus wurde dabei durch Alice abgelöst und Denise durch Lisa. Die Auflösungen reichen bis 1280x512 bei VGA-Ablenkfrequenzen. Die Farbpalette umfaßt nun 24 Bit oder 16,8 Mio. Farben, angezeigt werden können bis zu 256 Farben gleichzeitig oder im HAM-Modus bis über 640.000. Die Rückwärtskompatibilität zu Video- und OCS-Modi ist gewährleistet.

Für Information über den Chip, der für Die Soundausgabe verantwortlich war, siehe Sound.

Andere, interessante Dinge:

  • Der HAM-Modus (Hold And Modify) ist einer von mehreren Grafikmodi, der schon immer von den AMIGA-Spezialchips zur Verfügung gestellt wurde. Mit ihm kann man trotz geringem Speicherbedarf viele Farben gleichzeitig darstellen. Kurz ausgedrückt stellt er eine Hardware-Datenkompressionsmethode um ca. den Faktor drei (mit dem alten Chipsatz: zwei) dar. Trotzdem kann man praktisch alle Farben der Palette auf einem Bild verwenden. Durch die nachträgliche Modifikation der Farbe können vor allem weiche Farbübergänge sehr korrekt dargestellt werden, wie sie für natürliche Bilder wie Porträts charakteristisch sind. Im HAM8-Modus kann man so theoretisch über 640.000 verschiedene Farben auf dem Bildschirm darstellen. Durch die Abhängigkeit vom Vorgängerpunkt ergeben sich Beschränkungen, so daß der HAM-Modus weniger für Echtzeit-Aktion geeignet ist. Bei stehenden Bildern aber auch bei vorberechneten Animationen kann er seine Farbenvielfalt dagegen voll ausspielen. Mit seiner Datenkompression ist der HAM-Modus mit dafür zuständig, daß der AMIGA für seine Animationen so berühmt ist, die auch auf den kleineren Modellen in voller Geschwindigkeit laufen können. Grundsätzlich gilt, daß man im HAM8-Modus alle Farben der 24-Bit-Palette darstellen kann, also 16,8 Millionen.
  • Copper ist der Kurzname für einen "Coprozessor", der in die AMIGA-Spezialchips integriert ist. Er ermöglicht schnelle Actionspiele, unglaubliche Farbeffekte und z. B., daß man beim AMIGA einen Bildschirm wie ein Rollo teilweise herunterziehen kann, um den dahinterliegenden Schirm gleichzeitig zu betrachten. Technisch gesehen ist der Copper ein hochspezialisierter Mikroprozessor, der nur drei verschiedene Befehle kennt, diese aber ungemein schnell und effektiv abarbeiten kann. Er sorgt dafür, daß man z. B. Grafikmodi, Farbwerte oder Spritedefinitionen mitten auf dem Schirm wechseln kann, um so noch mehr Effekte gleichzeitig auf einem Bild unterbringen zu können.
  • Blitter ist der Kurzname für einen weiteren Grafikprozessor, der Teil der AMIGA-Spezialchips ist. Mit ihm können rechteckige Bildteile extrem schnell an andere Plätze kopiert werden. Durch logische Verknüpfung von bis zu drei Quelldatenbereichen kann man z. B. erreichen, daß bestimmte Farbwerte des zu kopierenden Objekts transparent wirken und den Hintergrund im Zielbereich nicht verändern. Daneben kann der Blitter auch schnell Linien ziehen oder Flächen füllen. Insgesamt verhilft er also zu extrem schneller, bewegter Grafik, die besonders realistisch gestaltet werden kann.


Sound

Mit diesen Optionen kann festgelegt werden, ob und wie UAE Sound unterstützt.

WinUAE - Sound

Sound Emulation

Disabled schaltet die Sound- Emulation aus.

Disabled, but emulated schaltet die Soundausgabe aus, emuliert im "Amiga" aber den Sound

Emulated emuliert und gibt den Sound aus.

Emulated, 100% accurate emuliert die ganz Sound-Hardware. Es ist fast kein Unterschied hörbar, die Emulation wird aber viel langsamer. Verschiedene Programme (AIBB) laufen aber mit anderen Einstellungen nicht.

Frequency, Sample Type und Stereo

Diese Optionen erlauben die Einstellungen für das Sound - Sampling. Je höher Frequency und/oder Sample Type eingestellt werden, desto besser wird die Qualität der Ausgabe, desto langsamer wird jedoch auch die Emulation. Das gleiche gilt für Stereo.

ACHTUNG: Sound in hoher Qualität setzt einen sehr schnellen PC vorraus!

Sound Output Method

Die Soundemulation benutzt zwei verschiedene Systeme, um den Sound auszugeben. Eines davon ist DirectSound, das andere (WaveOut) benutzt MMSystem (MultiMediaSystem), das schon ein Teil von Windows seit Version 3.x ist.

WaveOut hat 2 verschiedene Ausgabemethoden:

  • Looping schreibt die Sounddaten in einmal in einen Puffer, und spielt diese dann ab.
  • DblBuff kontrolliert, ob die Ausgabe beendet wurde.

DirectSound hat die gleichen Methoden, benutzt aber das DirectSound System. Dies kann oft die Kompatibilität verbessern, wenn deine Soundkarte mit WaveOut nicht funktioniert. DirectSoundNotification kontrolliert, wie weit DirectSound mit der Ausgabe bereits ist.

Hintergrundinformation:

Der 3. Custom Chip des Amias, Paula war für die Audioausgabe und andere I/O Aufgaben zuständig. Der Chip beherrschte vier Stimmen, die auf 2 Kanälen (Stereo) ausgegeben wurden. Die Tonlage umfaßte 9 Oktaven mit Amplituden- (z.B. für Sprachwiedergabe) und Frequenzmodulation.
Amplitudenmodulation war der normale Weg, Sound zu produzieren. Dabei las der DMA chip die Amplitudeninformation vom Speicher und der Chip wandelte die Werte in ein analoges Signal, das dann auf den Lautsprechern ausgegeben werden konnte.


Diskettenlaufwerke

Floppies

Bei dieser Karte können für den Start des "Amiga" Disketten in die "Laufwerke" gelegt werden.

WinUAE - Diskettenlaufwerke

Mit den Knöpfen ... können .adf - Dateien ausgewählt werden, die dann von UAE als Diskette im Amiga erscheinen. Mit Eject werden die Disketten sozusagen aus dem/den Laufwerk(en) genommen.

Mittels Create Blank "Floppy" können "leere" .adf - Dateien erzeugt werden. Diese sind dann in UAE praktisch als leere Disketten anzusehen.

Für mehr Informationen über adf - Dateien und deren Erzeugung, schau dir die Vorraussetzungen und Transdisk an.

WinUAE unterstützt gzip-gepackte Disk-Images. Wenn du eine 32 Bit (!) gzip.exe installiert hast, kannst du deine Disk-Images (.adz) und ROMs (.roz) in komprimierter Form ablegen. Die gzip.exe muß im gleichen Verzeichnis sein, in dem sich WinUAE.exe befindet! Komprimierte Dateien werden schreibgschützt sein.

Es können auch mit DMS gepackte Dateien mit WinUAE verwendet werden. Dazu muß sich lediglich die Ausführbare Datei xDMS in einem Verzeichnis befinden, auf das die Path-Variable zeigt (z.B. c:\windows\command\).

Wenn du Windows NT benutzt: Wenn die Kompression von NTFS anstatt von gzip verwendet wird, kann auf die Dateien auch geschrieben werden, und die Verwendung von gzip wird sinnlos!


Festplatten

Hard Drives

Diese Karte beinhaltet einige sehr wichtige Einstellmöglichkeiten, da mit diesen dem "Amiga" Festplatten zur Verfügung gestellt werden können.

WinUAE - Festplatten

Add Directory...

Mit diesem Knopf wird ein Fenster aufgerufen, in dem man den Ordner auswählen kann, der dann als Festplatte in UAE erscheinen soll.

Add Hardfile...

WinUAE - Festplatteneinstellungen

In diesem Feld können die verschiedenen Einstellungen für eine Festplattendatei getätigt werden. Unter dem Feld Hard File Settings können die Eigenschaften der Datei (Sektoren, Oberflächen, usw.) wie bei einer echten Festplatte für den Amiga festgelegt werden. Die Standard - Einstellungen sind eigentlich recht gut gewählt.

Harddisk files sind große Dateien, die ein Amiga Dateisystem enthalten. Das Prinzip ist gleich wie bei Disk Images. Eine derartige Datei kann einfach erzeugt werden und als leere Festplatte in UAE eingebunden werden. Vor der Benutzung muß es - wie jede normale Festplatte auf dem Amiga - zuerst mit dem "Amiga" formatiert werden.

Wenn du Kickstart 1.3 oder früher verwendest, können Hard files nicht im Amiga gemounted werden, daher kann auch nicht von ihnen gebooted werden. Du wirst entweder von einem Floppy Disk Image oder von einem Dateisystem booten müssen, und das hardfile.device später hinzufügen.

Um das zu bewerkstelligen, füge das Folgende zu "DEVS:mountlist" hinzu:

UAE0:
Device = uaehf.device
Unit = 0
Flags = 0
Surfaces = 1
BlocksPerTrack = 32
Reserved = 1
Interleave = 0
LowCyl = 0 ; HighCyl = 511
Buffers = 5
DosType = 0x444F5300
BufMemType = 1

Wenn du andere Einstellungen für die virtuelle Platte getroffen hast, mußt du diese hier natürlich einsetzen! Dann, gib einfach "mount DH0:" (oder schreib das in die startup-sequence), und das Hard file sollte erscheinen.

Remove

Um eine virtuelle Festplatte wieder sozusagen "auszubauen", muß diese nur ausgewählt werden, und auf "Remove" gedrückt werden.

Properties

Mit diesem Knopf wird das selbe Fenster wie mit der Option Add Hardfile... . Damit können alle Einstellungen der virtuellen Festplatte dann verändert werden.

Add PC Drives at Startup fügt alle PC-Laufwerke innerhalb von UAE hinzu. Damit werden alle PC- Laufwerke auf dem Amiga verfügbar.

  • Wenn das Laufwerk unter Windows einen Namen hat (z.B. Daten), dann wird es auch im "Amiga" mit diesem Namen erscheinen.
  • Wenn nicht, dann wird das Laufwerk mit folgendem Namen eingebunden (das 'x' steht für den PC Laufwerksbuchstaben):
Festplatten | WinDH_x:
CD-ROM Laufwerke | WinCD_x:
Diskettenlaufwerke | WinDF_x:
Netzwerklaufwerke | WinNW_x:
Austauschbare Laufw. | WinRMV_x:
RAM Disk Laufwerke | WinRAM_x:

ACHTUNG: Wenn in ein Laufwerk kein Medium eingelegt ist (z.B. CD_ROM, Floppy), dann wird dieses Laufwerk NICHT für den Amiga verwendet.


Schnittstellen & Eingabegeräte

Game and I/O Ports

Diese Optionen beeinflußen wie ein Amiga-Joystick emuliert wird. Hier werden auch die Einstellungen für die serielle und parallele Schnittstelle und den MIDI-Port getätigt.

WinUAE - I/O

Serial:

Hier kann die PC-Schnittstelle eingestellt werden, die dann im "Amiga" als serielle Schnittstelle fungiert. Dabei werden nur die Schnittstellen zur Auswahl angeboten, die Windows tatsächlich zur Verfügung hat. Shared weist UAE an, die Schnittstelle mit Windows zu "teilen", d.h. daß beide Systeme darauf zugreifen können.

MIDI

Hier kann das MIDI - Gerät, das verwendet werden soll, eingestellt werden. Dabei wird auf die DirectX - Treiber zugegriffen.

Parallel

In dem Feld kann die Parallele Schnittstelle des PC's angegeben werden, die dann dem Amiga zur Verfügung gestellt wird.

Amiga Mouse Port 0 / 1

In diesen beiden Optionsfeldern werden die "Geräte" an den beiden "Anschlüssen" für den Amiga eingestellt. Normalerweise ist am Port 0 des Amiga eine Maus angeschlossen, d.h. es ist "PC Mouse" ausgewählt. Über den Knopf swap kann man die beiden Anschlüsse ohne großen Aufwand vertauschen.

Für die Emulation eines Joysticks gibt es 3 verschiedene Konfigurationen:

 | Konfiguration A | Konfiguration B | Konfiguration C
Auf | Ziffernblock 8 | Cursor Auf | T
Ab | Ziffernblock 2 | Cursor Ab | G
Links | Ziffernblock 4 | Cursor Links | F
Rechts | Ziffernblock 6 | Cursor Rechts | H
Feuer | Ziffernblock 0 | Rechte Control | Linke ALT


Verschiedenes

Misc.

Hier können viele wichtige Aspekte der Amiga-Emulation festgelegt werden.

WinUAE - Verschiedenes

Advanced:

Middle-Mouse-Button --> ALT-TAB belegt den mittleren Mausknopf (falls vorhanden) mit der Kombination ALT+TAB, welche zum wegschalten von UAE (auf andere Tasks) verwendet wird.

Log illegal memory accesses schreibt illegale Speicherzugriffe ind die Datei winuaelog.txt, wenn Create log file aktiviert ist.

Show GUI on startup schaltet das GUI aus, wenn UAE über eine Konfiguration gestartet wird (Doppelklick auf eine .uae - Datei).

Create log file wird verschiedene Informationen bei jedem Start der Emulation in die Datei winuaelog.txt schreiben.

AutoConfig wird verwendet, um Festplatten und Speicherkarten für Kickstarts >1.3 zu mounten. Bei Kickstart 1.3 und darunter muß diese Option ausgeschaltet werden!

BSD socket library emulation erlaubt deinem Amiga, die Netzwerkverbindung des PC's zu nutzen. Entweder durch eine DFÜ - Verbindung oder ein Ethernet. In anderen Worten, wenn dein PC mit einem ISP (Internet Service Provider) verbunden ist, kann der Amiga darauf zugreifen.

Show LEDs when full-screen stellt die LED's wie bei einem echten Amiga dar (z.B. Power-LED, Disketten- und Festplatten- LED). Die Auflösung muß jedoch höher als 800x600 sein.

Custom-Chip Blits:

Immediate : Die Emulation "wartet" nicht, bis der blit fertig ist. Einige Spiele und Demos verlassen sich jedoch darauf, daß der blit zuerst fertiggestellt wird, also sollte diese Option für bestmögliche Kompatibilität ausgeschaltet werden.

32-bit blits sind etwas schneller, können aber auch die Kompatibilität negativ beeinflussen.

When Minimized:

Run at lower priority führt dazu, daß UAE den Prozessor weniger belastet, wenn es minimiert ist.

Disable sound output schaltet die Tonausgabe aus, wenn UAE minimiert ist.

Hintergrundinformation:

  • Der Zorro-Bus ist der Standard für Erweiterungskarten auf den größeren AMIGA-Modellen ab dem AMIGA 2000. Dort war es ein Zorro-II-Bus, der 16 Bits breit war. Ab dem AMIGA 3000 gibt es den Zorro-III-Bus, der eines der schnellsten 32-Bit-Bussysteme war. Er ist daneben abwärtskompatibel zum Zorro-II-Bus. Eine ganz wichtige Eigenschaft dieses Bussystems ist die Autoconfiguration.
  • Auf anderen Rechnersystemen müssen Steckkarten mühselig mit "Jumpern" auf bestimmte Adreßlagen und Interrupt-Nummern eingestellt werden. In der Praxis erfordert das oft tiefgreifende Systemkenntnisse, um Konflikte zwischen verschiedenen gleichzeitig eingesteckten Karten zu lösen. Der Autoconfig-Mechanismus des AMIGA-Systems automatisiert diesen Vorgang komplett, so daß der Benutzer sich nie um solche Details kümmern muß. Erweiterungen von AMIGA-Systemen werden auf diese Weise extrem einfach und problemlos.


Die Emulation

Wenn die Emulation erst einmal läuft, ist der schwierigste Teil der Bedienung von UAE vorbei :).

Amiga - Workbench 3.1

Es gibt jedoch auch dann noch einige wichtige Dinge, die man wissen sollte:

  • Picasso96 Emulation
  • Kommandozeilenoptionen
  • Tastaturemulation
  • Dateisystem
  • Kompatibilität
  • Geschwindigkeit


Picasso96 Emulation

Um die Emulation für Picasso 96 nutzen zu können, mußt du den 68020 mit 32 Bit Addreßraum als CPU einstellen. Es wird mindestens ein Kickstart ROM Version 3.x benötigt.
Den Regler für den Grafikspeicher der emulierten Picasso 96 Karte findest du bei RAM unter RTG Memory. Der Speicher des RTG hängt mit der Bildschirmeinstellung zusammen. Das heißt, es kann keine Auflösung von 1600x1200 verwedet werden, wenn nur 1 MB Grafikspeicher bereitgestellt wurde!

Als nächstes benötigst du die Picasso 96 Treiber für den Amiga. Diese Treiber sind nicht im WinUAE - Paket, du kannst sie aber hier hier downloaden. Es wird empfohlen, Version 1.31 oder höher einzusetzen. Installiere die Picasso96 Software. Wenn das geschafft ist, wird der "Amiga" neu gestartet, und du kannst die neuen Grafikmodi mit dem ScreenModes Programm im Amiga auswählen und benutzen.


Kommandozeilenoptionen

WinUAE hat so gut wie keine Optionen mehr, die über eine Kommandozeile eingegeben werden können, weil jetzt ein GUI für die Konfiguration des Emulators verwendet wird.

Dennoch gibt es zwei Parameter, die wichtig sein könnten:

  • -config=configfile.uae
  • -f configfile.uae

Diese Parameter werden WinUAE dazu veranlassen, daß es gleich mit der angegebenen Konfigurationsdatei startet, und haben die gleiche Bedeutung.


Tastaturemulation

Die meisten Tasten der Tastatur behalten ihre ursprüngliche Funktion auch unter UAE, aber es gibt einige Ausnahmen:

  • Wenn du KEINE Win95 - Tastatur (oder WinNT) hast, mußt du die Kombination Ins/Home als Ersatz für die Amiga-Tasten benutzen.
  • HELP wurde auf die Taste "Bild ab" umgeleitet.
  • F12 öffnet das GUI.
  • Scroll Lock schaltet die Bildschirmaktualisierung um (die Emulation wird dadurch schneller).
  • Pause schaltet den Sound um, ebenfalls gut für die Geschwindigkeit (ACHTUNG: UAE muß dafür schon mit Sound gestartet werden!).
  • End+F1, F2, F3 or F4 erlaubt dir, die Disketten in den 4 virtuellen Laufwerken zu Ändern (mit .adf - Dateien).
  • Shift+End+F1...F4 nimmt die Diskette aus dem Laufwerk.


Dateisystem - Eigenheiten

UAE versucht, die Brücke zwischen dem Amiga- und PC- Dateisystem so gut wie möglich zu schlagen (Das Amiga- Dateisystem ist von Tripos).
Aber es gibt einige Limitationen:

1. Das Windows-Flag "read only" (nur lesen) kontrolliert das W und D Bit auf der Amiga-Seite.
2. R und E sind immer gesetzt.
3. H, S und P können nicht gesetzt werden.
4. Das A - Flag wird aufbewahrt.
5. Es wird kein Datei- Kommentar unterstützt.
6. Nicht alle Dateinamen, die unter Windows verboten sind (z.B. / \ * " ? < > und | im Dateinamen) werden nicht korrekt behandelt (bis jetzt jedenfalls). Die häufigsten sind es aber.

ACHTUNG: UAE "lebt" nicht in einer Unix - ähnlichen Umgebung (chroot, Mount-Punkte usw.)! UAE kontrolliert nicht, ob irgendein Amiga- Programm auf Ordner überhalb des Mount-Punktes zugreift! Du kannst dir nicht absolut sicher sein, daß ein verrücktspielendes Amiga - Programm deine anderen Daten gefährdet!


Kompatibilität

Wenn du Probleme mit einem bestimmten Programm oder Spiel hast, schau dir die Links an. Dort findest du die besten Seiten zu WinUAE im Internet!

Die Zahl der Programme, die nicht richtig unter UAE laufen, werden mit jeder neuen Version weniger. Wenn du ein Programm findest, daß eine spezielle "Behandlung" braucht, dann laß es die Entwickler wissen (der derzeitige Verantwortliche für WinUAE ist Brian King - siehe Kontakte).

Die meisten Kickstart-Versionen funktionieren. Es gab auch Berichte über den erfolgreichen Einsatz von 68020 Kickstart - Versionen. Einige spezielle A600 Versionen, die sich auf IDE und/oder auf einen PCMCIA - Slot verlassen, funktionieren nicht korrekt.

In UAE sind die Probleme mit Sprites noch immer nicht ganz behoben. Die Unterstützung des AA - Chipsatzes ist zur Zeit in noch sehr frühen Stadien. Aber auch die Emulation des OCS funktioniert (noch) nicht perfekt (z.B. die Kollisionsabfragen).

Einige spezielle Programme brauchen "Instruction Prefetch" und/oder "Exception 3" (z.B. Shadow of the Beast I, Katakis and Denaris). Diese Optionen können im GUI unter CPU mit der Option "compatible-mode" eingeschaltet werden.


Geschwindigkeit

Auf einem ausreichend schnellem PC kann UAE durchaus mit einem echten Amiga mithalten.
Dank DirectX ist der reine Zeichendurchsatz dieser Version der beste aller Intel- Versionen. Auf einem Pentium 100 ist die Auflösung 800x600 nur zirka 20% langsamer als 320x200, trotzdem mehr als 7mal so viele Pixel über den Grafikbus "gepumpt" werden. Die normale Farbtiefe von UAE ist 16 Bit. Diese Tabelle zeigt, wie die Geschwindigkeit von UAE von der Bildschirmmodus abhängig ist:
16 bpp als Vollbild - 100%
16 bpp im Fenster - 98%
24 bpp im Fenster - 72%
32 bpp im Fenster - 60%

Leider verlangsamt die Fensterdarstellung einige Systemdienste, wie zum Beispiel die Tastatur- und Mauseingabe. Zur Zeit gibt es leider keinen Weg, dies zu umgehen.SMP- Maschinen (d.h. Maschinen mit mehr als einem Prozessor) sind davon nicht betroffen.

Allgemein gilt: Sound ist Luxus. Weil die Soundausgabe strikt mit der Grafikausgabe synchronisiert werden muss, wirst du _nie_ eine gute Soundausgabe bekommen, wenn dein Computer nicht mindestens 50 fps (frames per second = Bilder pro Sekunde) zu Stande bringt.

Faustregel: Besorge dir einen PPro oder Pentium II/III wenn du Grafik und Sound in der vollen Qualität gleichzeitig haben willst. Je schneller dein Computer, desto besser :)

Auf einem Pentium 100 mit einer Matrox Millennium, ist UAE-Win32/DirectX ein bißchen schneller als die Linux-Version, wenn der Bildschirm oft erneuert werden muß (z.B. bei Spielen). Alles andere sollt mit ungefähr der gleichen Geschwindigkeit laufen.

Brian Kings Entwicklungssystem:

  • Intel Celeron 300A Prozessor übertaktet auf 450MHz
  • WinNT 4.0, Service Pack 3
  • Ensoniq AudioPCI
  • nVidia Riva 128 AGP
  • 128-MB SDRAM (PC-100)
  • 28x CD-ROM Laufwerk (ATAPI)
  • 2x/8x CD-R Laufwerk (SCSI)
  • Microsoft Natural Keyboard und eine Intellimouse
  • ViewSonic Optiquest V95 19" Monitor, Auflösung: 1600x1200, 16-bit Farbtiefe

Dieses System erreicht normalerweise (nach Brian's Angaben) die Geschwindigkeit eines "echten" Amiga 3000 (68030 mit 25MHz), und Picasso96 RTG Geschwindigkeiten von mindestens einer PicassoII Karte.


Autoren - Informationen

In dieser Sektion findest du Informationen über UAE, dessen Programmierer und die Hilfe, die du gerade liest!

Wenn du einen der Programmierer (oder mich selber) kontaktieren willst, beachte folgendes: Frage NIE um irgendwelches Material, das Rechtlich geschützt ist (wie die Kickstart-ROMs, Workbench-Disketten usw...)! Sendet NIE irgendwelche Programme, Texte oder Sonstiges!

Die Sektionen:

  • Über WinUAE
  • GPL
  • Über diese Hilfe


Über WinUAE

Ó 1995-1999 Bernd Schmidt : Entwickler von UAE für Linux (der Ur-Version von UAE).
Ó 1996-1999 Mathias Ortmann : Win32 - Version und bsdsocket emulation.
Ó 1996-1999 Brian King : Win32 - Version, Picasso96 RTG, und GUI.
Ó 1998-1999 Toni Wilen : AGA Chipsatz, NTSC/PAL Modi.

Und viele andere, die Code zum Gesamtprojekt beigetragen haben:

Alessandro Bissacco, Hannu Rummukainen, Andre Beck, Ed Hanway, Denis Sablic, Marcus Sundberg, Samuel Devulder, Stefan Reinauer, Marco Nelissen, Thierry Lescot, Bruno Coste, Oliver Moehrke, Per Olofssen, Tristan Cavelier, Ruben Martinez, Olivier Raoul, Markus Gietzen, Christian Schmitt, Herman ten Brugge, Tauno Taipaleenmaki, Michael Krause, Kai Kollmorgen, Stefan Ropke, Joanne Dow, Rodney Hester, Volker Zota, David Varley, Holger Jakob, Philippe Gerin, Jake Hamby, Chris Hames, Paul Kienitz.

Sieh dir die Links für die Homepages von WinUAE und dem eigentlichen UAE an!

Falls du einen Fehler entdeckt hast, lies dir zuerst die Bekannten Fehler durch, bevor du einem der Autoren eine Mail schreibst!

BEACHTEN: Gib genaue Angaben über das System, das du verwendest:

  • Amiga OS Verion (Kickstart und Workbench)
  • Laufende Erweiterungen (MagicWB, NewIcons, DirOPUS, ToolManager, usw.)
  • Einstellungen des Amigas, die das Problem verursachten
  • Windows - Version (Win95, Win95a, Win95b, Win95c, Win98, WinNT, usw.)
  • DirectX Version
  • PC Grafikkarte und ihre Treiberversion
  • Soundkarte und ihre Treiberversion


GPL - GNU Public License

GNU GENERAL PUBLIC LICENSE
 Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

GNU GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you". Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program. You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:
a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.
b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.
c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.
Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.
In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:
a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,
b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,
c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

<one line to give the program's name and a brief idea of what it does.>
Copyright (C) 19yy <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) 19yy name of author Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'. This is free software, and you are welcome to redistribute it under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program `Gnomovision' (which makes passes at compilers) written by James Hacker.

<signature of Ty Coon>, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Library General Public License instead of this License.


Über diese Hilfe

Die Hilfedateien wurden im HTML - Format mit Frontpage98 Editor entworfen. Die Bilder editiert und/oder erstellt mit Photoshop 5. Die Dateien wurden mit dem HTML Help Workshop zu der .chm - Datei kompiliert.

DirectX, HTML Help Workshop, FrontPage, Windows 95,98 und Windows NT Ó Microsoft Corporation

Photoshop Ó Adobe Systems, Inc.

Amiga, Kickstart, Workbench und the Amiga Logo sind Ó Amiga, Inc.

Amiga Forever Ó Cloanto

Alle anderen Markennamen sind Ó ihrer jeweiligen Hersteller!

Danke an:

  • Brian King, der Informationen zu UAE zur Verfügung stellte
  • Toni Wilen, auch für Informationsbereitstellung
  • Hippie2000 (Back2Roots) für seine großartige Hilfe
  • JayBee (AIAB) für seine Hilfe mit der Dateigröße
  • Bobic (Back2Roots) für einige nützliche Vorschläge
  • Nomad, für das neue Logo
  • Alle, die mich über Fehler informiert haben

Irgendwelche Fehler in der Datei gefunden? Verbesserungsvorschläge? Schreib mir!

ACHTUNG: Die Erstellung dieser Datei war viel Arbeit, deshalb informiere mich, wenn du irgendwas für deine Zwecke verwenden willst!

Diese Hilfedatei ist Ó 1999, 2000 Georg Veichtlbauer und unterliegt nicht der GPL!